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SATA-IP User Guide on KC705

Revl.1 06-Mar-13

Referring to 1-ch SATA host demo on KC705 Evaluation board, this document describes how to
update hardware by using Vivado2012.4/EDK14.4 and how to update firmware in the demo by
using SDK14.4.

1. DDR3 IP Update (AR#53420)

This demo uses MIG v1.8 IP core for controlling DDR3 memory. Following AR#53420 of Xilinx
website, default IP core in Xilinx installation directory has the problem and it needs to install the
patch to fix this bug. User is recommended to download “mig_v1 8 calibration_patch.zip” from
http://www.xilinx.com/support/answers/53420.htm and install it to wuser platform before
re-implement the demo project.

2. Vivado Tool

2.1 Overview

Project Manager - system_stub - SATA_h_notimeout_kc705
Sources = A il
a, iZj e : J”"'" o E system_stub.cache
".- _1- 'Deéiu-;r;“S-uurces E-ID-K-SuB-syslelr1 and its wrapper system_stub.data
-l gw System_stub - STRUCTURE (=y<bem_sbub,vhoi (1) L system_stub.runs
foiepye Es?smm—" Systomt Sy star Xmp) o 8 = systern_stub.sdk
[Z) sata_host.elf | MicroBlaze firmware from SDK =~ — — —7 '-\“.:‘ 4 systern_stub.srcs
-7 Constraints (1) ~ - . — 3. constrs_1
=} constrs_1 ___,_.._-;:-—"_
—_—— = sim_1
H3] system_stub.xdc | Project Constraint File — — b - -
[#-5 Simulation Sources 11 . 4 sources_1
~
~ 4 edk
=3
- system
P
bootloops
data
etc
poores
simulation

Figure 2-1 Demo system on Vivado Tool

The demo is designed based on EDK sub-system. “system_stub.vhd” is generated to be the
wrapper file of EDK sub-system, so this file needs to update if port of EDK sub-system is modified.
User can check details of EDK sub-system by double-click from icon in Vivado tool or opening
directly from “system_stub.srcs/sources_1/edk/system” folder. More details of EDK sub-system is
described in next topic.

The demo includes MicroBlaze to control SATA-IP operation and its firmware (sata_host.c) will
be compiled to “sata_host.elf” file by SDK tool. By including “sata_host.elf” into Vivado project, the
final bitstream “system_stub.bit”, stored in “system_stub.runs/impl_1" folder, will built-in the
firmware and FPGA can boot the demo after configuration complete. SDK project is stored into
“system_stub.sdk” folder and the details of SDK tools will be described later.
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2.2 How to update design in Vivado

- If EDK sub-system is modified, user should right-click at EDK icon and select “Reset
Output Products...” to clean up sub-system netlist, as shown in Figure 2-2.

[=]-fz7 Design Sources (2)

I?_}---.'_-LI?‘-,,‘*, system_stub - STRUCTURE (systern_skub,whd) (1)
P cvsbem_j - syskem (system., xmp)l
== ELF (1) = Source Mode Properties.., Ctrl+E
“[X sata_host.elf 2 .
[=)-{=7 Constrainks (1) il Orenfile 50
[} conskrs_1 Gao To Instantiation F7
Y systemn_stub,xde
[=-+{= Simulation Sources (1) Create Top HDL
-G sim_1 (2] Wiews Instantiation Ternplate
Create Testbench
Generate Output Products...
I Reset Qutput Products... I
Export Hardware for SDK...

'l":igljre 2-2 Reset EDK sub-system

- Select “Generate Bitstream” menu to start re-implementation the project, as shown in
Figure 2-3.

4 Implementation
ﬁ. Implementation Settings
[» Run Implementation

> % Open Implemented Design

4 Program and Debug
ﬁ. Eitstream Settings
m Generake Bitstream
E Cpen Hardware Session
W Launch iMPACT

Figure 2-3 Re-generate bitstream
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3. EDK Tool

3.1 Overview

@ Bustnterfaces | ports | Addresses |

A A L L
0 4 M M
oo aa lwm [E"Wu
AL axi_inkerconnact
= E EDK Install :_; ao-:l_rhrm‘rm::
@ Analog am & nterconned
W Arithmetic is Imb_vi0
- Bus and Bridge ZL Imb_vi0
# Clodk, Resst and Interrupt e microblaze
SATAIP transfers data with DDR3 RAM - L"'ﬁ} -
|| — -
through AXI4 bus as Master 'F 32 \b_beam F etk
[ FPGA Reconfiguration %, ! ram Z auc Imby_bram_§_entle
- General Purpose 10 3 [+ e axl_Teeres_ddrx
- Interprocessor Communication ‘ B L ek OlZa_connechor
] Memsory and Memory Controler ! 1 il @ e mdm
# PCI ey r
#- Peripheral Conkroller \ g% % m
e _ L 240 -
A Lkilky Ireiby_bram_if_cokir_0_BRAM_PORT =
- Varficalon — & DUSL TR COuTEr 34 ad_timer
i Video and Inage Processing =5 --f A |5 sz : axl_uart 16550
= Prajeck Local PCores - | clock_panarator_ 0 k. COCK_Qenerafor
B LISERH v - I PO Eye recal O e Proc_gys_reset
o 20 a 3o e it
= :1:?':2!‘??};;3;:?;}::; E:; ?s 'E:E';la';"ﬂ MicroBiaze writefread controd register of
RIS 2yl B9-  SATA-IP through LMB Bus UF
|

Figure 3-1 SATA-IP demo system on EDK tool

In EDK sub-system, SATA-IP with additional logic to connect the IP to system by using standard
bus is called “axi42sata” module. “axi42sata” module is imported to EDK system and displayed in
IP Catalog in the left window, as shown in Figure 3-1. To interface with “axi42sata”, two standard
bus interfaces are designed, i.e. AXI4 bus for data transferring with DDR3 and LMB bus for
control register with MicroBlaze. In this system, clock frequency of AXI4 bus is equal to 200 MHz
for synchronous with DDR3 frequency while LMB bus clock frequency is equal to 150 MHz for
synchronous with MicroBlaze frequency.
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3.2 AXI2SATA Folder

“axi42sata” stuff is stored into pcores\axi2sata vl 00 a folder. The details of each file are

follows.
=] |29 SATA_h_notimeout_ke705 5] axi42sata_v2_i_0.bbd
® 5 _xps (] axi4zsata_v2_1_0.mpd
£ bactlesps ;| B axi42sata_v2_1_0.pao
) data /!
2 ete / B AXI925ATA, vhd
1) implementation / !Eoob_control.vhd
= |2 peores > /J !Esata?phy_k?.vhd
{1 i | axi425ata,vtf_DD_a 7 E;Espeed_neg_:ahtrol.vhd
5]+~
= hdl ¥ [ﬂ]asyncfifomzxsz.ngc
1 vhd =] asyncifoS12x36.ngc
— — — = Ffa2tezse.nge
& 2 50K =] Frzsetosz.nge
g sata_lt_ll.ngc
Figure 3-2 Folder/File List within axi42sata module
“data” folder

- axi42sata v2 1 0.bbd: List the netlist files which is used within “axi42sata” module

FILES
lasyncfifo.512x32.ngc, asyncfifod12x36.ngc, F£256t032.ngc, FEf32t0256.ngc, sata 1t 11.ngc

Figure 3-3 BBD file of axi42sata module
- axi42sata_v2_1 0.pao: Contain a list of HDL files

1ib axid2sata vl 00_a oob_control vhdl
1lib awi42sata vl 00_a speed ney_control vhdl
1ib axi42sata vl 00 a sataZphy k7 vhdl

1ib axid42?sata vl _00_a awid2?sata vhdl

Figure 3-4 PAO file of axi4sata module

- axid42sata_v2_1 0.mpd: Define the interface of peripheral such as port list, bus interface,
parameter
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BEGIH axid2sata

## Peripheral Options

OFPTIOH IFTYPE = PERIFHERAL
OPTION IMP HETLIST = TRUE

OPTIOH IP GROUP = MICROBLAZE:USER

OPTIOH ARCH SUPPORT MAF = {OTHERS=DEVELOFPMEHT)
OPTIOH STYLE = MIX

## Bus Interfaces

BUS THTERFACE BUS = M AXT, BUS STD = AXI, BUS TYPE = MASTER

BUS_THTERFACE BUS = PORTA, BUS STD = XIL BRAM, BUS TYPE = TARGET

HPARAMETER ¢ M AXT ADDR WIDTH = 32, DT = IHNTEGER, BUS = M A¥T, ASSIGHMENT = CONSTAHT

PARAMETER C M AXT DATA WIDTH = 256, DT = INTEGER, BUS = M AXT, ASSIGHMENT = CONSTANT

HPARAMETER € M AXT PROTOCOL = AXT4, TYPE = HON_HDL, ASSIGHMENT = CONSTANT, DT = STRING, BUS = M AXI
HPARAMETER € M AXT SUPPORTS HARROW BURST = 0, DT = INTEGER, BUS = M AXT, ASSIGHMENT = CONSTANWT

##f Generics for VHDL or Parameters for Verilog

## Ports
PORT Clk
PORT R=tB
PORT AXIArReady
PORT AXIArValid

ARESETH, DIR I, BUS = M AXT
ARREADY . DIR I, BUS = M AXT

"', DIR = I, SIGIS = CLK, BUS = M AXI
ARVALID, DIR = 0, BUS = M AXI

PORT AXTAwReady
PORT AXTAwValid
PORT AXTAwAddr

AWREADY, DIR = I, BUS = M AXI
AWWALID, DIR = 0, BUS = M AXI
AWADDR, DIR = 0, VEC = [31:0], ENDIAW = LITTLE, BUS = M AXI

EORT BRAM Rst A
PORT BRAM C1k A
PORT BRAM EN A

ERAM Rst, DIR = I, BUS = PORTA
BRAM Clk, DIR = I, BUS = PORTA, SIGIS = CLK
ERAM EH, DIR = I, BUS = PORTA

PORT MGTCLK W ="", DIR =1
PORT MGICLE P = "", DIR =1
PORT MGT BXP = "", DIR =1
PORT MGT BXW ="', DIR =1
PORT MGT TXP = "', DIR = 0

PORT MGT TXW DIR =0

Figure 3-5 MPD file of axi4sata module

“hdl/vhd!” folder
- AXI42SATA.vhd: Top module of axi42sata which includes SATA-IP, SATA-PHY, and
additional logic for bus interface
- sata2phy_k7.vhd: SATA-PHY hdl code which includes speed negotiation and OOB control
- speed_neg_control.vhd: HDL code for auto speed negotiation function
- oob_control.vhd: HDL code for OOB timing control

“netlist” folder
- asyncfifo512x32/512x36.ngc: netlist within SATA-IP
- sata_It_ll.ngc: SATA-IP netlist
- Ff256t032/32t0256.ngc: FIFO netlist which uses within AXI42SATA for converting bus size
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3.3 How to update AXI2SATA

If demo project is designed by using Vivado, Step 6) — 8) can be skipped and change to start
re-implement on Vivado tool instead.

To update “axi42sata” module, user can follow the below steps.

1) Close EDK tools if the project is opened.

2) Update AXI42SATA.vhd code

3) Add/Remove port list in “axi42sata_v2_1 0.mpd” when port list is changed. Then, open
“system.mhs” file to add/remove connection of “axi42sata” with system.

4) If any hdl code is added into sub module of “axi42sata”, please store new hdl code to
“hdl/vhdl” folder and store new netlist to “netlist” folder. Then, update file list within
“axi42sata_v2 1 0.bbd” and “axi42sata v2_1 0.pao”.

5) Open “system.xmp” by EDK and check all system connections.

6) Select Hardware->Clean Hardware menu to clean up previous backup file

@ File Edit VYiew Project | Hardware Device Configuration Debug
JJ @ (%] @ - JJ f3: F_ f3: enerate Metlist

Mavigatar X |

IPC f Generate Bitstream

ﬂ Create or Import Peripheral. ..
Design Flow D
I =f’ Configure Coprocessor, .

: é} Launch Clock \Wizard. ..

Check and Yiew Core Licenses. ..
Run DRCs

'ﬂﬁ Clean Metlisk

Implement: Flows i1 Clean Bitstream

&
Figure 3-6 Clean Hardware menu

7) Select Device Configuration->Update Bitstream to start re-implementation

| Dievice Configuration  Debug

§.| Dowrload Bitstrearn

Figure 3-7 Update bitstream

8) Wait until implementation complete. “download.bit” configuration file will be updated and
stored in “implementation” folder.
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4. SDK Tool

4.1 Export from EDK Tool

This topic describes about how to generate new SDK project from EDK tool. If user only updates
“sata_host.c”, step 3) — 10) can be skipped.

1) Export hardware from EDK to SDK workspace by selecting “Export Design” icon and “Export

& Launch SDK”.

_ Tricl Flow Il Export to SDK / Launch SDE _?;ﬁ“
@ This dialog allows vou to export hardware
il /" platfarm information to be used in SDK.
B
Generate WNetlist
I¥ Include bitstream and BMM file
e (%P5 will regenerate bitstream if necessary,
1014 and it may take some kime ko finish.)
Generate BitStream
Cirectory location For hardware description files
#| =DK\SDK_Export
Expart Design | Expart Orily I [Expnit & Launch SDKI Cancel | Help

Figure 4-1 Export Hardware to SDK

2) Select “workspace” folder. In demo project, “workspace” is subfolder within “SDK” folder. Then,
hardware platform will be exported to project explorer of SDK, as shown in Figure 4-3.

4 Workspace Launcher ﬂ

Select a workspace

iliny: SDK skores vour projects in a folder called a workspace.
Choose a workspace Falder ta use For this session,

Workspace: I D:\SATA-IFYSATA_h_notimeout_k-7054SDK workspace| ﬂ Browse. .. |

I Use this as the default and do not ask again

2013/03/06

| oK I Cancel
Figure 4-2 Select SDK workspace
|._|>_‘| Project Explorer &3 =0
==

|E| E SATA_h_notimeout_le 705 _ww_plakform |
----- |=| swstem_bd.brmm
----- |=| swstem, bit

Figure 4-3 Hardware platform in SDK
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Select “standalone” and then click “Finish”.

4 C/C++ - SATA_h_notimeout_kc705_hw_platform/system.xoml - Xiling SDK
| File Edt Source Refactor Mavigate Search Run Project X Tooks  Window Help

T Mew Board Support Package Project

3) Generate “Board Support Package” by selecting File->New->Xilinx Board Support Package.

¥ilinx Board Support Package Project m

Create & Board Suppost Package,

Profect name: | standslons_bsp 0

¥ U dafaul location

(et (O ATAPEATA]

TSSO {orizp s standalons_bip 0

Chirase e ssxtem

Hardwars Matform: ESATn_h_mtm.t_k:mS_hw_phLForm

OPL: I|.-..:|-_-: fze 0

k]
E|

sikeinel Standalone is a simgle, ow-lrvel softiare layer, It provides acoess to basic

Features such as caches, ntarrupts and exceptions as well as the basic

Featuras of a hosted anvironment, such as standard input and output, profiing,
abort and exit,

()

e ] cone

Figure 4-4 BSP Generating

4) In Library option, click OK after setting complete. After that, bsp folder will be generated and

displayed on project explorer of SDK, as shown in Figure 4-5.

T Board Support Package Settings %l
Board Support Package Settings
Control various settings of your Board Support Package,
prywrs standalone_bsp_0
= drivers 05 Typs:  stancabing Standalone & & simple, low-level software layer. It provides access to
o 3068 basic processor features such as cachas, interrupts and excepbions as
OS5 Versiong 17 well 33 the basic features of & hosted environerent, such &= standand

Irput and output; profiling, aboet and exdt;

Hardware Specification; DiLSATA-TFYSATA_h_notimeout ke 051 S0K work \SATA_h_notimacuk_KE705_bw,
Processor: mecroblaze_ i o e -
i Project Explorer 83 L)
| -}— =
Check the box neut b the Branes you want inchided in your Board Suppoet Package. You can configure the : St
i i £ saTA_h_notimeout_ke705_hw_platform
[rane [vssion [ Description [ | syskern_bd . brim
O keptso 1.02.8 bwilP TCP/IP Stack Mrary: halP w1 4.0, diinx sdepter v1.... <2 syskem, bit
O siatis 1.00.a Provides read)vaibe routines o access files stored ona P, | __ " I
Ol sibiach 3028 silrue Flach Horary For Intel/AMD CF1 comphant par.sbe lssh [ el sysemam
OO st 3.00,8 sl In-systern and Serisl Flash Library # [f# standalone_bsp_0
O siis Lo.a Solrox Mesnory File Siesbem 1
(?) [ o | coma |
Figure 4-5 BSP Generating complete
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5) Create new C Project by selecting File->New->Xilinx C Project, as shown in Figure 4-6.

4 C/C++ - standalone_bsp_0/system.mss - Xilinx SDK

File Edit Source Refackor Mavigate Search Run Project  ¥ilinx Tools ‘window Help

AletshifeH P |

Open File... @ ilinz C++ Project
Close Chrl+4e &7 wilinx Hardware Platform Specification
Close All Chrl+shife+w Wiy #ilinx Board Support Package
—ao
Froject...
Save Chrl5 L Froj

Figure 4-6 New C Project

6) Select “Empty Application” from Project Template, and type project name such as “sata_host”
to Project name box. Click “Next” button to continue next step.

_ioix

New Xilink C Project

L
Create a managed make application project, Choose From one of the sample
applications,

Prajeck name: | sata_hostl

V¥ Use default location

Loratian; | DA SATA-IPYSATA_h_notimeout_k-705, 50K \workspacelsata_he Browse. .. |
I~
I~

zhoose file system: Idefault 'I

—Target Hardware

Hardware PlatFarm: ISAT.C\_h_notimeout_kc?DS_hWJ:IatFDrm

Processar: Imicrnblaze_ﬂ

r Target Sofbware

Software Flatform: * Standalone © Linux

rSeleck Project Template

Dihrysbone | [ Description
8 blank C project,
Hello Warld ey d
IwIP Echio Server
Memory Tesks ;I LI
@:I = Back I ek = | | Eirish I Zancel

Figure 4-7 Define Project name

7) Click to select “Target an existing Board Support Package” and select “standalone_bsp_0".

After that, click “Finish” to complete setup. New project (“sata_host”) will be displayed on
project explorer, as shown in Figure 4-8.
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£ Mew Project

New Xilins C Project

Create a mansged maks apphcation profect. Chaose from ons of the sampls

apphications.

™~ Creste & new Board Support Packags project

=10 x|
€
/A

I ik gt () Project Explorer 33\"\\_ =0
28 [TE TA.I RE7O5 & v
: =i
&8 saTA h notimeout_kc705_hw_platfarm
| [Target an existing Board Support Packagel ——

T T H [t Includes

standatone_bsp_0 {05: standalona) i E l--'._-l Src
& (M standalone_bsp_0

<pck | v |[Ewh ] el |

Figure 4-8 Selecting BSP for C Project

8) Create new C source code by right click at project name folder (“sata_host”) in project
explorer->New->File.

[ Project Explorer 53 = Eq ﬂ_g syskearn, xrl ﬂrﬂh system. mss 23\
==

standalone_bsp_0 Board Su

{3 SATA_h_notimeout_kc705_hw_plakForm
i p—

[ Project...

| * File from Template

Cipen in Mew Window

--@ star |12/ Copy Chri+c [ Falder
Figure 4-9 Create new C file

9) Select “src” folder and type file name such as “sata_host.c”. Click “Finish” to complete, and
new C code (sata_host.c) will be displayed on project explorer in “src” folder, as shown in

Figure 4-10.

2013/03/06
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4 New File
File

Create a new file resource.

Enter or select the parent folder:

=0l

] sata_host/src

| L Project Explorer 3?.\‘\\_7

™
&

e SATA_h_notimeout_kc705_hw_platform
== sata_host

& 5rc
{5 standalone_bsp_0

= E‘
& =
=

= sata_host

2 Includes
= Debug
3 SIC

File name: |$ata_hcst‘-: I
Advanced >> I

ﬂ Iscript.ld
i [} README.txt
(M standalone_bsp_0

@ o

Figure 4-10 Add C source code

# 3 SATA_h_notimeout_ke705_hw_platform |
M€

10) Edit new C source code (“sata_host.c”). For 1% time usage, user needs to generate a linker
script by right click at project name (“sata_host”) and select “Geneate Linker Script”. Then,
click “Generate” button in new window to complete.

x|

i

Place Code Sections in: I localmemory _cntlr_i_localmemary_cntlr_d

Flace Data Sections in: I localmemary_cntlr_i_localmemary_cnitlr_d

Flace Heap and Stack in: | localmemary _cntlr_i_localmemary_cntlr_d

| Generate I

Cancel

L Frojest Explorer E3 = Olgws
= T
L i
[+ ;_ﬁ SATA_h_notimeout_ke705_hw_platfarm ::j
Mew 3
GoInto
Openin New Window
: = Copy Crl+C
Faste Chrl+y 4} Generate a linker script
¥ Delete Delete Generate linker script
MEvE
A Control your application's memory map.
Rename,,, P
g Import. ;
= Basic | Advanced I
2 Export, Project: sata_host
Build Project Output Script:
Clean Project | _h_niotimenut_ko70s1SDKworkspacelsata_hostisrcllscript i Browse |
o Refresh Fs Madify project build settings as follows:
C_Ilose o;elc: : . ISet generated script on all project build configurations ;I Heap Size: | 1 KB
Gloselinrelated Projects
Stack Size: | 1 KB
Build Configurations r
Maks Targets 3 Mernory | Base Address | Size |
Index > localmemary_cntlr_|_localmemary_cnt... 0x00000000 64 KB
ddr3_sdram_5_A%I_BASEADDR 0x50000000 16GB
oW I/ A0t Sstoms Vie Irnb_bram_ff_cntl_0 0x00010000 &4 KB
Convert To..,
Run &s +
Debug As
@
Profile As L2 i
Team L3
Compare With L
Restore from Local Histary...

B Generate Linker Script

Figure 4-11 Generate Linker Script

11) After user updates source code (“sata_host.c”), user can re-compile project by selecting
Refresh to update code and start re-compile operation.
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L1 Project Explorsr 2 =0 o svsl
= I
13 SATA_h_notimeout_ke705_hwe_platform j:j:
Lot
New 3
Go Into

Cpen in New Window

B @‘;‘E || Copy Chrl+C
Paste Chr
3 Delete Delete
aferi=s
Rename... Fz
g Import...
7 Export...
Build Project

Clean Project
3 Refresh

Close Project
Close Unrelated Projects

Figure 4-12 Refresh Project

12) To run on real board, select Xilinx Tools->Program FPGA. Then, press browse to select
“system.bit” and “system_bd.bmm” file from “hw_platform” folder and change elf file from
bootloop to new file such as “sata_host.elf”. Click Program to start FPGA programming.

x|
|
Program FPGA
¥ilinx Tools Window Help Specify the bitstream and the ELF files that reside in BRAM memory
Tel Generate linker script
Wi\, Board Support Package Settings ~Hardware Configuration
(@ Repositories Hardware Specification: D:\SATA-IP\SATA_h_notimeout_ke70S\SDK\workspace\SATA_h_notimeout_kc70S_hw_platformisystem.xml
Bitstream: ID:\5MA-IP\SATn_h_notimenut_kc705'|SDK?,wnrkspaca\,ShTA_h_nntimsnLt_kc?Dﬁ_hw _platformisystem.bit Il EBrowse., I
Program Flash BMM File: ID:I,SATA-IP\,San_h_nol:imeout_kc?fJ"S'qSDK\workspacei,SATA_h_notimeow:_h:?l:ﬁ_hw _p!atfcwm'l,system_bd.bmml ] Browse.. I
[3€] xMD Console Software Configuration
B Launch Shell Processor | ELF File to Initiakze in Block RAM
£} Configure JTAG Settings microblaze_0 ut_kc705\5DK\workspacesata_hostiDebualsata host.elff = |
3¢ System Generator Co-Debug Settings sata hostiDebuaisata host,elf
[ create Boot Image
@ Progan | Cancel

Figure 4-13 FPGA Programming on SDK

13) Wait programming complete and new firmware will be updated to FPGA.
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4.2 Export from Vivado Tool
This topic describes about how to generate new SDK project from Vivado tool.

1) Before exporting hardware, select “Implemented Design” menu to open design details in
Vivado.

2) Export hardware from Vivado to SDK workspace by selecting File->Export->Export Harware
for SDK... and then check box for “Launch SDK” following before click “OK” button. After this
step, “system_stub.sdk” folder will be created in project directory and SDK workspace is
defined to “../SDK/SDK_Export” path.

4 Implementation | File | Edit Flow Tools ‘“Window Layo
@;. Implementation Setkings F New Project...
[» Run Implementation ¥ Open Project
C [g] Irnplemented Design # Open Recent Project b
ﬂ Edit Timing Conskraints Open Example Project S

6 Report Timing Summary
e, Report Clock Metworks

@ Add & Alb+d
:l_] Report Clock Interaction & RHcEs +
0 Report DRC Open Source File.. Ctrl + M
FE report Noise Export [l Export Hardware for SDK...
%] Report Utilization Open Log File
Report Power " : -
i # Exrort Hardware far 308 |

o Export hardwars platfoem for SOK.

Opbiore
SR r‘ SystemL T
Export b i) slocal b Praject >
Workspace: | B <Locl Do Projedt >
| Irechade bitstroam (Moke: an mglsmented design musk be loaded)
o | Export Hardvware

[¥] Laurech 508

o [

Figure 4-14 Export for SDK by Vivado Tool

3) Continue next step by following step 3) in Topic 4.1 “Export from EDK Tool”. The step for both
EDK and Vivado is similar, but SDK workspace path is different.
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5. Revision History

Revision Date Description
1.0 18-Feb-13 Initial release
1.1 06-Mar-13 Support Vivado tool

Copyright: 2013 Design Gateway Co,Ltd.
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